Bug #24

Unicorn check for dolfin version is not consistent.

Added by Tobias Nilsson about 5 years ago. Updated over 4 years ago.

Status:ResolvedStart date:11/13/2012
Priority:NormalDue date:
Assignee:Niclas Jansson% Done:

0%

Category:-
Target version:-

Description

The scripts download and install dolfin-hpc version 0.8.2, but the configure.ac for Unicorn checks for version 0.8.3 of dolfin-hpc.

History

#1 Updated by Niclas Jansson about 5 years ago

Yes, the DOLFIN and Unicorn releases has slip slightly out of sync. There is a set of preconditioners that some Unicorn solver uses. These preconditioners were defined after DOLFIN 0.8.2 were released.

A workaround is to redefined unicorns configure script, change the line

PKG_CHECK_MODULES([DOLFIN], [dolfin = 0.8.3-hpc])

into

PKG_CHECK_MODULES([DOLFIN], [dolfin = 0.8.2-hpc])

and run regen.sh to regenerated configure.

This also reminds me that I should fix the remaining issues that prevents DOLFIN 0.8.3 from being released.

#2 Updated by Aurélien Larcher almost 5 years ago

  • Status changed from New to Resolved
  • Assignee set to Niclas Jansson

Solved by Niclas with newer dolfin-hpc and unicorn versions.

#3 Updated by Tobias Nilsson over 4 years ago

Hi! Should the bug status really be 'resolved' for this?
I got the same error again. Will use the suggested workaround.

.
.
.
checking for DOLFIN... no
configure: error: Package requirements (dolfin = 0.8.2-hpc) were not met:

Requested 'dolfin = 0.8.2-hpc' but version of DOLFIN is 0.8.3-hpc

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables DOLFIN_CFLAGS
and DOLFIN_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
make: *** [config] Error 1

Also available in: Atom PDF