Bug #103

error when loading mesh with 3M cells

Added by Niyazi Cem Degirmenci about 4 years ago. Updated about 4 years ago.

Status:RejectedStart date:09/29/2013
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

the mesh at /afs/nada.kth.se/dept/na/ctl/cem/vocal_1.bin

can be loaded with 24 proceses but with 168 processes gives the following error on lindgren:

ncde@emil-login2:/cfs/klemming/nobackup/n/ncde/vocal_folds/scalingtest_assemble_facet_old> aprun -n 168 ./cube vocal_1.bin

Initializing DOLFIN version 0.8.2-hpc.
Running on 168 nodes with 1 thread each
loading mesh ...
terminate called without an active exception
_pmiu_daemon(SIGCHLD): [NID 00005] [c0-0c0s2n1] [Sun Sep 29 11:41:44 2013] PE RANK 87 exit signal Aborted
[NID 00005] 2013-09-29 11:41:44 Apid 1750957: initiated application termination
Application 1750957 exit codes: 134
Application 1750957 exit signals: Killed
Application 1750957 resources: utime ~8s, stime ~8s

with 168 processes

test code :

24
25 if(dolfin::MPI::processNumber() == 0)
26 dolfin_set("output destination", "terminal");
27 else
28 dolfin_set("output destination", "silent");
29 dolfin_init(argc, argv);
30 #ifdef _OPENMP
31 int threads = omp_get_max_threads();
32 #else
33 int threads = 1;
34 #endif
35
36 message("Running on %d %s with %d %s each", dolfin::MPI::numProcesses(),
37 (dolfin::MPI::numProcesses() > 1 ? "nodes" : "node"),
38 threads,
39 (threads > 1 ? "threads" : "thread"));
40
41
42
43 message("loading mesh ...");
44 Mesh mesh(argv1);
45 BoundaryMesh msh;
46 msh.init_interior(mesh);
47
48 MPI_Barrier(dolfin::MPI::DOLFIN_COMM);
49 message("loaded mesh ...");
50 MPI_Barrier(dolfin::MPI::DOLFIN_COMM);

--------------------
for compiling the code

module swap PrgEnv-pgi PrgEnv-cray
module swap cce cce/7.3.1.101
module swap xt-libsci xt-libsci/10.5.0
module add petsc/3.1.04
module swap acml acml/4.4.0
module add dolfin

is used

History

#1 Updated by Niyazi Cem Degirmenci about 4 years ago

the code gives the same error without 2 boundary mesh lines as well

#2 Updated by Niclas Jansson about 4 years ago

  • Status changed from New to Rejected

I can't reproduce the error. The code works fine for me, and I can load the meshes on any number of cores.

#3 Updated by Niclas Jansson about 4 years ago

Niclas Jansson wrote:

I can't reproduce the error. The code works fine for me, and I can load the meshes on any number of cores.

Check your DOLFIN installation, such that you haven't accidentally built it with threading and are using petsc.

#4 Updated by Niyazi Cem Degirmenci about 4 years ago

but I used the dolfin module here

0.8.2

#5 Updated by Niclas Jansson about 4 years ago

Niyazi Cem Degirmenci wrote:

but I used the dolfin module here

0.8.2

Ok, true than I get the same error as well.

The problem can be due to several things, remember that module is over 2 years old and should NOT be used anymore. The system have been upgraded numerous times and system libraries etc aren't as backward compatible as one would like. Also, the binary file reader has also evolve during this time, and some bugs leaks etc has been fixed

Also available in: Atom PDF